SupplyManager Outage
Incident Report for Engineering Innovation, Inc.
Resolved
SupplyManager server was reverted to an older software build due to issues with an update - server is up and running again at this time. Thank you for your patience!
Posted Feb 20, 2018 - 18:32 EST
Identified
The SupplyManager server is currently down due to updates - we hope to have it back up and functional shortly. In the meantime if you require clicks loaded on your machine, please reach out directly to the EII Customer Support Team. We appreciate your patience!
Posted Feb 20, 2018 - 15:49 EST
This incident affected: EII Services (SupplyManager Server).