Windowbook Server Outage
Incident Report for Engineering Innovation, Inc.
Resolved
This incident has been resolved.
Posted May 05, 2018 - 22:47 EDT
Investigating
We are currently investigating an issue regarding the Windowbook server - anyone attempting to generate SSFs will end up timing out and be unable to successfully generate SSFs. EII Support is continuing to escalate the matter with Windowbook at this time.
Posted May 04, 2018 - 22:15 EDT
This incident affected: USPS Outgoing Services (Windowbook API).