Intermittent Connectivity with Endicia Servers
Incident Report for Engineering Innovation, Inc.
Resolved
This incident has been resolved.
Posted Jun 20, 2018 - 18:37 EDT
Update
We are continuing to investigate this issue.
Posted Jun 20, 2018 - 18:35 EDT
Update
We have received notification that all Endicia systems are functioning normally at this time. We will continue to monitor for any further disruptions.
Posted Jun 20, 2018 - 18:34 EDT
Investigating
It has been brought to our attention that customers are experiencing intermittent connectivity with Endicia label servers. We are aware of the situation and are actively investigating the issue with Endicia Support.
Posted Jun 20, 2018 - 15:38 EDT
This incident affected: USPS Outgoing Services (Endicia System).